A common error upon AXS2LMS installation is the following:

Not Found (The requested URL /install/1/step/2 was not found on this server)

If you get the above-mentioned error first check if your server has rewrite rules on. If your installation is hosted on an Apache server, make sure that you have enabled mod_rewrite from your Apache settings.

If your installation is hosted on a IIS windows server, make sure that you have configured the web.config file properly. You will need to provide an alternative for the rewrite rules that accompany eFront.

You can use IIS’ import tool for importing existing .htaccess file (here is a handy guide). Alternatively, you can create the following web.config file and place inside the site’s root folder (for example, c:\Inetpub\wwwroot\www):

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <rewrite>
            <rules>
                <rule name="Imported Rule 1" stopProcessing="true">
                    <match url="^" ignoreCase="false" />
                    <conditions logicalGrouping="MatchAll">
                        <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" negate="true" />
                    </conditions>
                    <action type="Rewrite" url="index.php" appendQueryString="true" />
                </rule>
            </rules>
        </rewrite>
    </system.webServer>
</configuration>

The following screenshot depicts a common setup for IIS:

A second possible reason for this issue is that your VirtualHost configuration has disabled .htaccess files.

You must allow .htaccess files for this to work. To do this, change the AllowOverride setting to All instead of None (obviously this is one way to achieve this, it is not mandatory to use AllowOverride All if you don’t want to. You can always copy the rules to your main configuration file).